Welcome Guest, you are in: Login

wiki.projectionscentral.com

RSS RSS

Navigation





Search the wiki
»

PoweredBy

Install problems seen and their solutions

RSS
Modified on 2011/02/10 22:46 by kloynd Categorized as All users, Installation
There are many potential causes for installation problems with ProjectionsSuite. The most likely causes have to do with the user not having sufficient privileges. For example, the Database Administration Tool must be installed and executed under credentials that have adminstrative privilege on the target computer. Failure to do so will result in issues such as:

  • Attempting to install SQL Server without sufficient privilege will fail utterly, but without saying anything about privilege. And it will require full admin rights to uninstall successfully (which is necessary after the fail) and reinstall successfully.
  • Attempting to install the Database Administration Tool will generate the message "Unable to satisfy all prerequisites for DatabaseSetupUtility. Setup cannot continue... "
    The details of this message will show that the user does not have the required privileges.

Sometimes previous installation erros can cause the the ClickOnce cache to be corrupted. this problem is identifiable by the installation error "The referenced assembly is not installed on your system. (Exception from HRESULT: 0x800736B3)"

The only sure-fire way to fix this problem is to uninstall the offending application completely. If after uninstalling from the Control Panel you still get this error when trying to install a new version, then you will need to drill down into the ClickOnce folders and manually delete the existing folders. 

On XP   -   C:\Documents and Settings\[useraccount]\Local Settings\Apps\2.0
On Vista and Windows 7   -   C:\Users\[useraccount]\AppData\Local\Apps\2.0

Under this folder you would find two levels of obscured folder names find which folder holds the ProjectionsSuite apps and delete those folders.



Failure to update that admin tool and ProjectionSuite at the same time

Surprisingly, one failure that we have seen several times is the failure of the user to download both the admin tool and the ProjectionSuite app at the same time. Failure to do so will result in a popup when the user runs the application indicating "It appears that you have installed a new version of the ProjectionsSuite. You must verify the database is up to date..." The administrative user will need to install the admin tool, invoke it and press the "Run Required Scripts" button. This will update the database version number so that it matches what the application is looking for.

 

Staffing Pattern import tells you that you need to have the FoxPro driver installed

One of the more difficult install issues to track down is when you attempt to import, for example EDS data, and the importer tells you that you "Need to install FoxPro OLE driver" even though you or your admin user already installed the driver.

The fix for this is to invoke the DB admin tool and uninstall the FoxPro driver, then reinstall it. The difference is that on the "Select Installation Folder" page of the FoxPro installer you must be sure to select the "Everyone" radio button near the bottom of the page. See the attachment "VFPOLEDB Select Installation Folder Page.png" for a visual example.

ScrewTurn Wiki version 3.0.2.509. Some of the icons created by FamFamFam.